Redirigir un dominio a otro DNS

( redes / mikrotik )

Por lo general el DNS de los ordenadores dentro de la red local apuntarán al DNS del router Mikrotik, pero en alguna ocasión nos puede interesar que cierto dominio se consulte a otro DNS. Esto es especialmente útil cuando tenemos una VPN en el router y el dominio es xxx.priv (por ejemplo) que si consultamos a un DNS "normal" no sabrá que hacer con el .priv

;; Redirigir el dominio dominio.priv al DNS IP_DNS
;;
/ip firewall layer7-protocol
add comment="Forward zona dominio.priv" name=dominio.priv regexp=dominio.priv
;;
/ip firewall nat
add action=dst-nat chain=dstnat comment="Forward a DNS IP_DNS" connection-mark=dominio.priv-forward to-addresses=IP_DNS
add action=masquerade chain=srcnat comment="enmascara DNS dominio.priv" connection-mark=dominio.priv-forward
;;
/ip firewall mangle
add action=mark-connection chain=prerouting comment="Todo lo que vaya al DNS del router y sea zona dominio.priv (TCP)" dst-address=IP_ROUTER dst-port=53 layer7-protocol=dominio.priv new-connection-mark=dominio.priv-forward protocol=tcp
add action=mark-connection chain=prerouting comment="Todo lo que vaya al DNS del router y sea zona dominio.priv (UDP)" dst-address=IP_ROUTER dst-port=53 layer7-protocol=dominio.priv new-connection-mark=dominio.priv-forward protocol=udp

Debemos cambiar dominio.priv (no tiene por qué ser .priv) por el dominio que queramos que sea respondido por el DNS especificado por IP_DNS

Modificado el 28 Febrero, 2015
Creado el 28 febrero, 2015
   

Compartiendo conocimiento desde 1995 - I.M.D. I.M.D.