Configuración de un servidor PPTP en Mikrotik

( redes / mikrotik )

IMPORTANTE: PPTP es bastante inseguro por lo que se recomienda utilizar L2TP, de hecho en iOs 10 y MacOS Sierra ya NO se puede usar PPTP porque Apple lo ha quitado.

En el Mikrotik podemos configurar un servidor PPTP para tener nuestra propia VPN y de esta forma conectarnos a la red de nuestra casa u oficina remotamente como si estuviésemos en local con una IP de nuestra red.

Para ello seguimos estos sencillos pasos y tendremos un servidor PPTP en el Mikrotik:

;;
;; Servidor de VPN PPTP con profiles
;;

/interface bridge
set LAN arp=proxy-arp

;; indicamos IPs a asignar cuando se conecta
;; IMPORTANTE deben estar excluidas del pool DHCP general
;;
/ip pool 
add name="DHCP-PPTP" ranges=192.168.1.250-192.168.1.254

/ppp profile 
add name=PPTP-IN local-address=192.168.1.1 remote-address=DHCP-PPTP use-encryption=required only-one=yes change-tcp-mss=yes dns-server=192.168.1.1

/interface pptp-server server 
set authentication=chap,mschap1,mschap2 default-profile=PPTP-IN enabled=yes max-mru=1460 max-mtu=1460

/ppp secret 
add name=usuario1 service=pptp password=contraseña1 profile=PPTP-IN
add name=usuario2 service=pptp password=contraseña2 profile=PPTP-IN

;; regla para permitir el PPTP
;; NOTA: cuidado esta línea debe estar por encima del DROP
;;
/ip firewall filter
add chain=input protocol=tcp dst-port=1723 action=accept comment=”Servidor PPTP

Podemos crear cuantos usuarios necesitemos aunque podrán conectar tantos como IPs hayamos reservado en el POOL y que dichas IPs DEBEN estar excluidas del DHCP local para evitar conflicto de IPs.

La IP 192.168.1.1 es el router que en mi caso también hace de DNS server, en caso de que NO coincidan debes indicar la IP del servidor DNS.

Los nombres del pool (DHCP-PPTP) y del profile (PPTP-IN) son opcionales y se pueden poner lo que veamos oportuno, por ejemplo si tenemos varios Pooles o Profiles para distinguirlos, pero deben ser únicos.

Un punto que puede dar problemas es la MTU que deberemos ajustarla según nuestras necesidades.

Por último tener en cuenta al añadir el filtro del Firewall que lo hagamos por encima del DROP que al ser un comando ADD lo añade al final y si tenemos un DROP (que deberíamos) se añadirá tras él, lo más simple para moverlos es vía naegador arrastrando la línea del filtro. El comentario podemos poner lo que queramos o quitarlo (no lo aconsejo, siempre es bueno poner un comentario por simple que sea).

Modificado el 16 Octubre, 2016
Creado el 5 enero, 2016
   

Compartiendo conocimiento desde 1995 - I.M.D. I.M.D.