Cisco serie 800: 3 - Configuración ADSL2+

( redes / cisco_ios )

Configuración de ADSL2+ para Cisco 877 (o cualquier modelos de la serie 800) para el proveedor Jazztel con IP dinámica (pero con mínimos cambios puede servir para otros operadores).

Para configurar la parte WAN con IP dinámica tenemos esta parte de configuración:

!
! Configuracion ADSL2+ Jazztel
!
interface atm 0
 description Jazztel DSL line Phone #[PONER EL NUMERO]
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 dsl enable-training-log
 no shutdown
interface atm 0.1 point-to-point
 no snmp trap link-status
 pvc 8/35
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1
interface dialer 1
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname __USUARIO__
 ppp chap password __CLAVE__
ip route 0.0.0.0 0.0.0.0 dialer 1
dialer-list 1 protocol ip permit

Aquí debemos cambiar 3 cosas:

  1. description -> Podemos poner lo que queramos o simplemente no ponerlo
  2. __USUARIO__ -> Es el usuario que nos proporciona Jazztel
  3. __CLAVE__ -> Es la clave que nos proporciona Jazztel
!
! LAN + NAT
!
ip name-server 87.216.1.65
int vlan 1
 ip address __IP_LOCAL__ __MASCARA__
 ip nat inside
interface dialer 1
 ip nat outside
ip nat inside source list 1 interface dialer 1 overload
access-list 1 permit __RED__ __WILDCARD__

Aquí debemos cambiar 4 cosas:

  1. __IP_LOCAL__ -> es la IP que tiene el router y es el GATEWAY de los ordenadores de la LAN, por lo general será 192.168.1.1
  2. __MASCARA__ -> es la MASCARA de la red de nuestra LAN, por lo general será 255.255.255.0
  3. __RED__ -> es la RED de nuestra LAN, por lo general será 192.168.1.0
  4. __WILCARD__ -> es la WILDCARD de nuestra red, por lo general será 0.0.0.255

También podemos cambiar el servidor de DNS que utilizará el router en ip name-server 87.216.1.65, ese es uno que proporciona Jazztel.

Con esto nuestro router sincronizará con el proveedor y la LAN saldrá a internet. Esto es solo la configuración de ADSL pero falta la parte básica y no hay protección de ningún tipo ni mapeo de puertos ni usuarios.

Modificado el 28 Junio, 2015
   

Compartiendo conocimiento desde 1995 - I.M.D. I.M.D.