CCNP Switch - Lab - LACP con STP

( redes / certificaciones / ccnp_route-switch / switch / labs )

LACP con STP

Respuesta y explicación:

Each of these vlans has one host each on its port

SVI on vlan 1 – ip 192.168.1.11 with snm

Switch B –

Ports 3, 4 connected to ports 3 and 4 on Switch A

Port 15 connected to Port on Router.

Tareas a realizar:

  1. Use non proprietary mode of aggregation with Switch B being the initiator Assumed use LACP with B being in Active mode
  2. Use non proprietary trunking and no negotiation Assumed use switchport mode trunk and switchport trunk encapsulation dot1q
  3. Restrict only to vlans needed Assumed either vtp pruning or allowed vlan list. vtp pruning command did not seem to work on the simulator so landed using allowed vlan list
  4. SVI on vlan 1 with some ip and subnet given
  5. Configure switch A so that nodes other side of Router C are accessible Assumed this to mean that on switch A default gatway has to be configured.
  6. Make switch B the root

En el SW-B debemos configurar esto:

SW-B(config)# vlan 21
SW-B(config-vlan)# name Marketing
SW-B(config-vlan)# exit

SW-B(config)# vlan 22
SW-B(config-vlan)# name Sales
SW-B(config-vlan)# exit

SW-B(config)# vlan 23
SW-B(config-vlan)# name Engineering
SW-B(config-vlan)# exit

SW-B(config)# spanning-tree vlan 11-13,21-23 root primary

SW-B(config)# int range fa0/3 – 4
SW-B(config-int-range)# no switchport access vlan 98
SW-B(config-int-range)# switchport trunk encapsulation dot1q
SW-B(config-int-range)# switchport mode trunk
SW-B(config-int-range)# switchport trunk native vlan 99
SW-B(config-int-range)# switchport trunk allowed vlan 1,21-23
SW-B(config-int-range)# channel-protocol lacp
SW-B(config-int-range)# channel-group 1 mode active
SW-B(config-int-range)# exit

SW-B(config-if)# int port-channel 1
SW-B(config-if)# switchport trunk encapsulation dot1q
SW-B(config-if)# switchport mode trunk
SW-B(config-if)# switchport trunk native vlan 99
SW-B(config-if)# switchport trunk allowed vlan 1,21-23
SW-B(config-if)# no shutdown
SW-B(config-if)# end

SW-B# copy running-config startup-config

En el SW-A debemos configurar esto:

SW-A(config)# vtp mode transparent

SW-A(config)# spanning-tree mode rapid-pvst

SW-A(config)# vlan 21
SW-A(config-vlan)# name Marketing
SW-A(config-vlan)# exit

SW-A(config)# vlan 22
SW-A(config-vlan)# name Sales
SW-A(config-vlan)# exit

SW-A(config)# vlan 23
SW-A(config-vlan)# name Engineering
SW-A(config-vlan)# exit

SW-A(config)# vlan 99
SW-A(config-vlan)# name TrunkNative
SW-A(config-vlan)# exit

SW-A(config)#int range fa0/3 – 4
SW-A(config-int-range)#no switchport access vlan 98
SW-A(config-int-range)#switchport trunk encapsulation dot1q
SW-A(config-int-range)#switchport mode trunk
SW-A(config-int-range)#switchport trunk native vlan 99
SW-A(config-int-range)#switchport trunk allowed vlan 1,21-23
SW-A(config-int-range)#channel-protocol lacp
SW-A(config-int-range)#channel-group 1 mode active
SW-A(config-int-range)#exit

SW-A(config)# int port-channel 1
SW-A(config-if)# switchport trunk encapsulation dot1q
SW-A(config-if)# switchport mode trunk
SW-A(config-if)# switchport trunk native vlan 99
SW-A(config-if)# switchport trunk allowed vlan 1,21-23
SW-A(config-if)# no shutdown
SW-A(config-if)# end

SW-A(config)# int range fa 0/9 – 10
SW-A(config-int-range)# switchport mode access
SW-A(config-int-range)# switchport access vlan 21
SW-A(config-int-range)# spanning-tree portfast
SW-A(config-int-range)# no shutdown
SW-A(config)# exit

SW-A(config)# int range fa 0/13 – 14
SW-A(config-int-range)# switchport mode access
SW-A(config-int-range)# switchport access vlan 22
SW-A(config-int-range)# spanning-tree portfast
SW-A(config-int-range)# no shutdown
SW-A(config-int-range)# exit

SW-A(config)# int range fa 0/15 – 16
SW-A(config-int-range)# switchport mode access
SW-A(config-int-range)# switchport access vlan 23
SW-A(config-int-range)# spanning-tree portfast
SW-A(config-int-range)# no shutdown
SW-A(config-int-range)# exit

SW-A(config)# interface vlan 1
SW-A(config-if)# ip address 192.168.1.11 255.255.255.0
SW-A(config-if)# no shutdown
SW-A(config-if)# exit

SW-A(config)# ip default-gateway 192.168.1.1
SW-A(config)# end 

SW-A# copy run start

NOTA: para saber la IP del Gateway podemos usar el comando "show cdp neighbors" en el SW-B

IMPORTANTE: copy run start did not work. Tried combos of wr, copy running-config startup-config, copy system:running-config nvram:startup-config. All variations did not work.

Modificado el 3 Enero, 2015
   

Compartiendo conocimiento desde 1995 - I.M.D. I.M.D.